The visual complexity of information on a map can be overwhelming, but you can simplify your view by applying filters to the data you are viewing. The Layer Filter tool lets you filter data within a layer by attribute. This creates a more focused view of the data you are examining. By filtering the data, you can reveal what is important and perform a better analysis. The tool allows multiple filters to be added to a single layer or multiple layers.
Follow the numbered instructions below the illustration to add a new layer filter.
Layers
IMPORTANT! Before you begin, you must have at least one layer turned on in the map. Please check that at least one layer is marked as visible.
Tools Tab
Select the Tools tab from the menu in the left-hand panel of the Map Viewer.
Expand Layer Filter
Expand the Layer Filter group by clicking the arrow so you can see the addition filter interface.
Select Layer
Select a layer from the drop-down list.
NOTE: If there are no visible layers on the map, you will get this message: No matches found. Please go to the Layer tab in the left-hand pane of the Map Viewer, and make sure at least ONE layer is visible. Then try selecting a layer again.
Query Builder: Attribute, Operator, Value
Select an attribute, operator, and value from the drop-down lists to build the query for your filter.
•Attribute (characteristic of interest)
•Operator (operation to be performed)
•Value (a record or piece of information from the values present within the selected field)
NOTE: You must select from the drop-down list; if you simply type the information, the field remains blank. To clear any selection you make, click the X on the right side of the selection.
Apply
Click Apply. The data displayed on the map is limited to the query statement that comprises your filter.
Layers Filtered
Notice the most recently selected layer appears at the bottom of the Layers Filtered list.
The icons next to each layer on the list mean the following:
Hover over the Info icon to see the query statement for the layer filter.
Click this icon to delete the layer filter.
Click this icon to populate the query builder with the existing query so you can edit it.
Create a New Filter
You can add another layer for filtering.
1.Click the Add button and select a new layer.
2.Next, enter new information into the Attribute, Operator, and Value fields. NOTE: If you make a mistake, you can always click Clear to clear the fields in the filter.
3.Click Apply and the new filter will appear under the Layers Filtered list. This allows you to filter multiple layers at once.
4.You can continue to add more filters in this manner.